Skip to content

Versions

Versions

Compute Framework Versions

Client Dependencies 2.7.x 2.6.x 2.5.x 2.3.x 2.2.x 2.1.x 2.0.x 1.5.x
EMR 5.19-5.30, 6.1.0-6.2.0 5.19-5.30, 6.1.0 5.19-5.30, 6.1.0 5.19-5.30, 6.1.0 5.19-5.30 5.19-5.30 5.11-5.28 5.3-5.23
Presto 0.210-0.232 0.210-0.232 0.210-0.232 0.210-0.232 0.210-0.232 0.210-0.232 0.187-0.225 0.170-0.225
PrestoSQL 350 350 338 338
Hive 2.3.2-3.1.2 2.3.2-3.1.2 2.3.2-3.1.2 2.3.2-3.1.2 2.3.3-2.3.6 2.3.3-2.3.6 2.3.2-2.3.6 2.1-2.3.4
Spark 2.3.2-3.0.0 2.3.2-3.0.0 2.3.2-3.0.0 2.3.2-3.0.0 2.3.2-2.4.5 2.3.2-2.4.5 2.2.1-2.4.4 2.0-2.4
Hue 4.2.0-4.6.0 4.2.0-4.6.0 4.2.0-4.6.0 4.2.0-4.6.0 4.2.0-4.6.0 4.2.0-4.6.0 4.0.1-4.4.0 4.0.1
Zeppelin 0.8.0-0.8.2 0.8.0-0.8.2 0.8.0-0.8.2 0.8.0-0.8.2 0.8.0-0.8.2 0.8.0-0.8.2 0.7.3-0.8.2 0.7.2-0.7.3
Databricks 8.0-8.2*, 7.3-7.6, 6.4, 5.5 7.3-7.6, 6.4, 5.5 7.3, 6.4, 5.5 7.3, 6.4, 5.5 6.4, 5.5 6.4, 5.5 5.5 5.5

Notes

  • Read about Okera compatibility and how it works.
  • Support for Databricks 8.0+ is only for the updated native Databricks integration.